pge projectirc.cat.biosmw central

PGE Project thread (Latest Editor 0.3.1.12 and Engine 0.2.6-alpha)

The second SMBX collab!
User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

ztarwuff wrote:
Wohlstand wrote:
ztarwuff wrote:Sorry to double post, but I just wanted to ask if anybody else has had difficulties opening up PGE Editor as of late? Recently, my Norton Security has decided that PGE Editor is untrustworthy, despite the fact that it's had no problems with it for the past year or so. I tried moving it back out of quarantine (scanned it fully and it's only File Insight that says its untrustworthy). That didn't work. I uninstalled and installed everything again. That still doesn't work.
"untrustworthy" is just a paranoia, so, mark it as exception and use it safely. Anyway, you can write to Norton's support about that message and please send them this link as source code of that thing:
https://github.com/Wohlhabend-Networks/ ... ter/Editor (code of editor only)
or better to this:
https://github.com/Wohlhabend-Networks/PGE-Project (code of entire PGE with all components, in readme are downloads and link to build guide)
How I understand, it just flags all apps as "untrustworthy" which are has no code-signed certificate (which usually costs a lot of money).

EDIT: I reported to Norton myself, so, I will wait their reply
EDIT: There are replied and there are confirmed detection and there are will fix that in next update ;-)
Unfortunately, that didn't solve the problem. I tried rolling back to a previous build of Windows 10 to see whether that was causing the problem.

Big mistake! I no longer have a functioning computer, so I'll be out of the game for a while.
Kill "Smart Screen" thing, it's dumb, I don't trust it myself :P

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

Hotfix
Hello!
Since some set of strong bugs are was found and fixed, all PGE applications are been updated!
(Version numbers are still same, but difference in the build number which a hex value in the Engine's title or inside About dialog of the Editor)

Fixes on the Editor side:
- Fixed bug with removed warp entrance point and after placing it again

Fixed on the Engine side:
- Fixed crash on NPC placement with interprocessing
- Sprite in real-time placing mode will be aligned to center of mouse rather left-top corner
- Background color of screen padding no is always black
- Player now can attack multiple NPC's at one stomp
- Player now can safely walk from ridable NPC's without jumps
- Removed workaround disables hurting of player while it flying up because player finally can safely stomp healthy NPC's

Common changes:
- Fixed a detection of libraries paths (such as "platforms") while dynamically built PGE Apps are locating in the folder with non-ascii path
- Added Music Player application allows you to play ALL supported by SDL Mixer X library (which a forked by me SDL Mixer v 2.0) music formats. You can use it just to test out loops, validly of sample rate (if sound plays shitty, you should re-sample it into 44100 hz, for mass resample of all musics in episode, use a special tool)

S1eth
Posts: 285
Joined: 2 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby S1eth » 1 year ago

If I create a Section 22 (or more), how do I delete those sections?
Image

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

S1eth wrote:If I create a Section 22 (or more), how do I delete those sections?
Open that section and then open menu:
Level -> Section modification -> Delete section, then confirm deletion.

That action removes >22 sections completely, but for 1...21 sections it will clean all data in section and will reset it's settings like you never opened that section..
Sections more than 21 are can be saved into LVLX format, SMBX64-LVL doesn't supports that

S1eth
Posts: 285
Joined: 2 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby S1eth » 1 year ago

Wohlstand wrote:
S1eth wrote:If I create a Section 22 (or more), how do I delete those sections?
Open that section and then open menu:
Level -> Section modification -> Delete section, then confirm deletion.

That action removes >22 sections completely, but for 1...21 sections it will clean all data in section and will reset it's settings like you never opened that section..
Sections more than 21 are can be saved into LVLX format, SMBX64-LVL doesn't supports that
I select Section 22, then Level-->Section Modifications-->Delete Section: "Do you want to remove all objects from this section?"-->Yes-->Section Margin: 32-->"Section 22 has been successfully deleted"

But even after doing that, Section 22 is still in the editor, and using Save still says: "The SMBX64 limit has been exceeded".
I am using editor 0.3.1.8 revision e00e03e (the editor that came with SMBX 2.0 BETA)
Image

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

S1eth wrote:
Wohlstand wrote:
S1eth wrote:If I create a Section 22 (or more), how do I delete those sections?
Open that section and then open menu:
Level -> Section modification -> Delete section, then confirm deletion.

That action removes >22 sections completely, but for 1...21 sections it will clean all data in section and will reset it's settings like you never opened that section..
Sections more than 21 are can be saved into LVLX format, SMBX64-LVL doesn't supports that
I select Section 22, then Level-->Section Modifications-->Delete Section: "Do you want to remove all objects from this section?"-->Yes-->Section Margin: 32-->"Section 22 has been successfully deleted"

But even after doing that, Section 22 is still in the editor, and using Save still says: "The SMBX64 limit has been exceeded".
I am using editor 0.3.1.8 revision e00e03e (the editor that came with SMBX 2.0 BETA)
Oh, anyway don't worry, you still can save file, that warning notifies you about lossy of some data (like those >21 sections), just press F8 to reload file

S1eth
Posts: 285
Joined: 2 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby S1eth » 1 year ago

Wohlstand wrote:just press F8 to reload file
Thank you, this was all I needed.
Image

User avatar
ztarwuff
What the heck is a flair and why am I being asked to write one for my profile?
Posts: 489
Joined: 3 years ago
Location: Within 2 miles of the Imperial Crypt of Napoleon III

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby ztarwuff » 1 year ago

A problem's just crept back up and I'm not sure what's causing it. If I set an entrance warp into a level from another level using PGE, it resets everything, including Collectable Leeks that a player has already collected. If I set it using the SMBX Editor, this problem doesn't happen.

Any ideas what's causing it?

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

ztarwuff wrote:A problem's just crept back up and I'm not sure what's causing it. If I set an entrance warp into a level from another level using PGE, it resets everything, including Collectable Leeks that a player has already collected. If I set it using the SMBX Editor, this problem doesn't happen.

Any ideas what's causing it?
Are you trying to modify level in hot mode? (while SMBX Episode is running and at same time PGE Editor is opened). Anyway that wired, and that usually not happens: I made a test episode with leeks and everything, and there are not reseting. Anyway I will try to test that.

This dummy episode successfully works with two-sided warps with no issues:
dummy episode (ztarwuff).zip
Dummy world with two warp<->warp levels
(1.45 KiB) Downloaded 8 times
You should place ONE warp point (mark it as "Exit") but don't worry, you still be able use it as entrance from another level! (this dummy test is showing everything!)

User avatar
ztarwuff
What the heck is a flair and why am I being asked to write one for my profile?
Posts: 489
Joined: 3 years ago
Location: Within 2 miles of the Imperial Crypt of Napoleon III

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby ztarwuff » 1 year ago

Wohlstand wrote:Are you trying to modify level in hot mode? (while SMBX Episode is running and at same time PGE Editor is opened). Anyway that wired, and that usually not happens: I made a test episode with leeks and everything, and there are not reseting. Anyway I will try to test that.
You should place ONE warp point (mark it as "Exit") but don't worry, you still be able use it as entrance from another level! (this dummy test is showing everything!)
No, not using hot mode at all but I do have separate warp points for entrances and exits.

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

ztarwuff wrote:
Wohlstand wrote:Are you trying to modify level in hot mode? (while SMBX Episode is running and at same time PGE Editor is opened). Anyway that wired, and that usually not happens: I made a test episode with leeks and everything, and there are not reseting. Anyway I will try to test that.
You should place ONE warp point (mark it as "Exit") but don't worry, you still be able use it as entrance from another level! (this dummy test is showing everything!)
No, not using hot mode at all but I do have separate warp points for entrances and exits.
Does my dummy episode works fine at you? I made it with freshest PGE Editor 0.3.1.9 which still in works (while I do important performance, memory and code optimizations) which you can take from laboratory (AppVeyor builds it every commit)

User avatar
ztarwuff
What the heck is a flair and why am I being asked to write one for my profile?
Posts: 489
Joined: 3 years ago
Location: Within 2 miles of the Imperial Crypt of Napoleon III

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby ztarwuff » 1 year ago

Yeah, it works fine. I guess I'll just do it the way you did it in your test.

It's weird that I can get the game to register more leeks than there actually are in the game. That's a weird bug.

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

ztarwuff wrote:Yeah, it works fine. I guess I'll just do it the way you did it in your test.

It's weird that I can get the game to register more leeks than there actually are in the game. That's a weird bug.
The thing is: when you adds new leeks while you already played episode - leek count was changed, and bug would appear because missmatches in the leek counters which are recounts when you adds/removes leeks from levels and when you did recound of total leek via world map (there is a button which counts total number of "stars" placed on plugged levels [it goes recursively to all accessible levels even for HUB-based worlds!])

User avatar
ztarwuff
What the heck is a flair and why am I being asked to write one for my profile?
Posts: 489
Joined: 3 years ago
Location: Within 2 miles of the Imperial Crypt of Napoleon III

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby ztarwuff » 1 year ago

Wohlstand wrote:
ztarwuff wrote:Yeah, it works fine. I guess I'll just do it the way you did it in your test.

It's weird that I can get the game to register more leeks than there actually are in the game. That's a weird bug.
The thing is: when you adds new leeks while you already played episode - leek count was changed, and bug would appear because missmatches in the leek counters which are recounts when you adds/removes leeks from levels and when you did recound of total leek via world map (there is a button which counts total number of "stars" placed on plugged levels [it goes recursively to all accessible levels even for HUB-based worlds!])
Oh no, I always wipe the save file before donig a new test so that shouldn't be a problem.

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.8 and Engine 0.2.4-alpha)

Postby Wohlstand » 1 year ago

ztarwuff wrote:
Wohlstand wrote:
ztarwuff wrote:Yeah, it works fine. I guess I'll just do it the way you did it in your test.

It's weird that I can get the game to register more leeks than there actually are in the game. That's a weird bug.
The thing is: when you adds new leeks while you already played episode - leek count was changed, and bug would appear because missmatches in the leek counters which are recounts when you adds/removes leeks from levels and when you did recound of total leek via world map (there is a button which counts total number of "stars" placed on plugged levels [it goes recursively to all accessible levels even for HUB-based worlds!])
Oh no, I always wipe the save file before donig a new test so that shouldn't be a problem.
Anyway, you may accidentally catched "reset game" menuitem in the SMBX and also you usually rejects saving to run test of levels made in PGE, so, try to modify level in SMBX, save it and then restart level without saving like you doing same with PGE (or run SECOND copy of SMBX and try to do same what you did in PGE and then run test in your "control" copy)

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Wohlstand » 1 year ago

New Update
This is a bugfix update and contains partial optimization works which are increase performance of editor and engine.
Sorry for a late update because long works over common optimization which are still in process. So, I sent my update because it contains important fixes for a bugs and some inconveniences. Anyway, Happy New Year!

Editor 0.3.1.9 changelog
* Fixed bug with removed warp entrance point and after placing it again
* Fixed a detection of libraries paths (such as "platforms") while dynamically built PGE Apps are locating in the folder with non-ascii path
* Added support of config pack's folder binding GIFs2PNG GUI (non-exist masks are will be retrieved from current config pack!)
* Use Bleeze theme on KDE, XFCE, OS X and on Windows 10
* Fixed bug with multi-selection item dialog where impossible to add NPC's into custom counter
* Added ability to copy any parameters/metrics of any placed element
* Added a good protection which avoids accidental running of multiple copies of engine for a testing


Engine 0.2.5 changelog
* Fixed crash on NPC placement with interprocessing
* Sprite in real-time placing mode will be aligned to center of mouse rather left-top corner
* Background color of screen padding no is always black
* Fixed a detection of libraries paths (such as "platforms") while dynamically built PGE Apps are locating in the folder with non-ascii path
* Player now can attack multiple NPC's at one stomp
* Player now can safely walk from ridable NPC's without jumps
* Removed workaround disables hurting of player while it flying up because player finally can safely stomp healthy NPC's
* Added experimental translator to have able to retranslated engine too
* Optimized memory usage and increased performance
* Now PGE Engine uses FreeImage library to load graphics
* Finally resolved a troubles with a lazily-made graphics, all masked-gif based graphics are merging via bit-blit algorithm


Screenshots
Image

Image


Also good news for GIFs2PNG: Now is supported ability to use config pack specific masks for episodes where are lacks masks by size reducing reasons. Without those masks target PNG will have black background because mask is not detected.

All downloads are available on the main page!

Note for OS X Users: PGE Engine will not work on OpenGL greater than 3.1 because it still use legacy functions. In works an update of PGE Engine's OpenGL to shader usage to finally take it working. Sorry for temporary inconvenient. But PGE Editor still works fine.

User avatar
Hoeloe
One of them Lua people
Posts: 812
Joined: 5 years ago
Location: Spaaace

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Hoeloe » 1 year ago

I'm having a gripe with the editor.

The grid snapping is painful. It works very well for objects that are sized as multiples of 32x32, but for anything oddly sized it's almost impossible to use. This is because it always snaps to the top left corner, which is only desirable in a very small number of cases, and makes it very difficult to align things with the ground.

Now, I suggest the following:

When an object is released, it should snap on whichever corner requires the least movement of that object. If you're very close to positioning it snapped on the bottom right, it should snap on the bottom right corner, rather than trying to snap on the top left. This way, objects can be positioned much more accurately in the grid, without forcing it to snap to any one specific edge.

This is currently causing quite a few problems for A2XT, so a relatively quick solution would be appreciated.

Also the scrollbars are basically useless, because they just skip over hundreds of blocks at the tiniest movement. I would suggest dynamically altering the range of the scrollbars based on the current section size.
Image
Image
Image
Image

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Wohlstand » 1 year ago

Hoeloe wrote:I'm having a gripe with the editor.

The grid snapping is painful. It works very well for objects that are sized as multiples of 32x32, but for anything oddly sized it's almost impossible to use. This is because it always snaps to the top left corner, which is only desirable in a very small number of cases, and makes it very difficult to align things with the ground.

Now, I suggest the following:

When an object is released, it should snap on whichever corner requires the least movement of that object. If you're very close to positioning it snapped on the bottom right, it should snap on the bottom right corner, rather than trying to snap on the top left. This way, objects can be positioned much more accurately in the grid, without forcing it to snap to any one specific edge.

This is currently causing quite a few problems for A2XT, so a relatively quick solution would be appreciated.
How you already know, Internally, all element's coordinates are based on left-top point. NPC's are using the "grid-offset" params to calibrate aligning to be more accurate. By default there are calculating automatically to align NPC to bottom-center of a default cell-size (32 px). Anyway thanks for idea to allow definition of grid alignment by specific corder/side (left-top[true position], left-center, bottom-left, bottom-center, bottom-right, center-right, top-right, center [element will be aligned at center of the cell]), so, there are easy-to-implement because internally I already has grid-offset bases thing to manipulate with alignments, so, I will need to append context menu and some functions to change grid-offsets per every element dependent to selected corner. ;)
Hoeloe wrote: Also the scrollbars are basically useless, because they just skip over hundreds of blocks at the tiniest movement. I would suggest dynamically altering the range of the scrollbars based on the current section size.
There are useful only for mousewheel-specific zone to scroll in a section faster without holding of CTRL/SHIFT keys. Anyway I think to change their range to "active" section too. You will be allowed to scroll far outside of the section only with arrows or mousewheel inside section, but scrollbars are will be limited with current section

User avatar
Willhart
Reader on the forums
Posts: 2490
Joined: 6 years ago
Location: Finland

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Willhart » 1 year ago

When I alter the gridsize on PGE to something else from the main.ini file, the backgrounds and the npc will not follow the new grid, even though the blocks do.
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Starting a new LP Here. Do give the game a look if you find it interesting.

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Wohlstand » 1 year ago

Willhart wrote:When I alter the gridsize on PGE to something else from the main.ini file, the backgrounds and the npc will not follow the new grid, even though the blocks do.
Default grid applying only if objects are has no redefined value in the lvl_block, lvl_bgo and lvl_npc, etc. Currently every background object and NPC are has grid= tag. If you wish to apply common grid, just remove all "grid=32" lines from those files and those elements are will use default grid size.

User avatar
Willhart
Reader on the forums
Posts: 2490
Joined: 6 years ago
Location: Finland

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Willhart » 1 year ago

Wohlstand wrote:
Willhart wrote:When I alter the gridsize on PGE to something else from the main.ini file, the backgrounds and the npc will not follow the new grid, even though the blocks do.
Default grid applying only if objects are has no redefined value in the lvl_block, lvl_bgo and lvl_npc, etc. Currently every background object and NPC are has grid= tag. If you wish to apply common grid, just remove all "grid=32" lines from those files and those elements are will use default grid size.
Thank you. That worked.
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Starting a new LP Here. Do give the game a look if you find it interesting.

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Big news!

Postby Wohlstand » 1 year ago

Hello!

Yesterday we are migrated PGE Project's and LunaLUA main site to a new server and we now finally have a separated domain name.

New location of PGE Project and LunaLUA downloads, PGE-Wiki, PGE Forums, etc. is here: http://wohlsoft.ru.
All links from engine.wohlnet.ru will be automatically redirected to a new place!
  • New server is going to be much faster for America, Australia and Asia (continents which are located far out off Moscow city)
  • More stability
  • Much more disk space for a file storing!

S1eth
Posts: 285
Joined: 2 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby S1eth » 1 year ago

I recently downloaded PGE again, and it appears that some things have changed.

How do I get PGE's "Test -->Test in SMBX" to use the SMBX editor I have already open instead of starting another instance of SMBX.

I have read this: FAQ
I want the behavior of the "older than 0.3.1.10-dev" version. Is this no longer possible in the new version?

I am also encountering this issue:
My level has loadImage lua code. ( Graphics.loadImage(Misc.resolveFile("mySubFolderWithinTheLevelFolder/someFileName.bmp")); )
This code executes normally when I open the level in SMBX editor.
But when I open it with PGE's "Test in SMBX", it cannot find the file.

The "templevel" folder created by PGE does not include my subfolder where the images are stored.
Image

User avatar
Wohlstand
PGE and LunaLUA developer
Posts: 152
Joined: 3 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby Wohlstand » 1 year ago

S1eth wrote:I recently downloaded PGE again, and it appears that some things have changed.

How do I get PGE's "Test -->Test in SMBX" to use the SMBX editor I have already open instead of starting another instance of SMBX.

I have read this: FAQ
I want the behavior of the "older than 0.3.1.10-dev" version. Is this no longer possible in the new version?

I am also encountering this issue:
My level has loadImage lua code. ( Graphics.loadImage(Misc.resolveFile("mySubFolderWithinTheLevelFolder/someFileName.bmp")); )
This code executes normally when I open the level in SMBX editor.
But when I open it with PGE's "Test in SMBX", it cannot find the file.

The "templevel" folder created by PGE does not include my subfolder where the images are stored.
Because PGE Editor doesn't copies BMP's into pre-generated dummy world (trick used by PGE Editor to launch SMBX Test requires generating of a dummy episode), convert your image into PNG and that will work fine. I'll fix that in next commit, and you will be able to take fixed editor from laboratory
EDIT: Sent, wait ~1 hour while AppVeyor will build it, then take fresh build here ;)

S1eth
Posts: 285
Joined: 2 years ago

Re: PGE Project thread (Latest Editor 0.3.1.9 and Engine 0.2.5-alpha)

Postby S1eth » 1 year ago

Wohlstand wrote:
S1eth wrote:I recently downloaded PGE again, and it appears that some things have changed.

How do I get PGE's "Test -->Test in SMBX" to use the SMBX editor I have already open instead of starting another instance of SMBX.

I have read this: FAQ
I want the behavior of the "older than 0.3.1.10-dev" version. Is this no longer possible in the new version?

I am also encountering this issue:
My level has loadImage lua code. ( Graphics.loadImage(Misc.resolveFile("mySubFolderWithinTheLevelFolder/someFileName.bmp")); )
This code executes normally when I open the level in SMBX editor.
But when I open it with PGE's "Test in SMBX", it cannot find the file.

The "templevel" folder created by PGE does not include my subfolder where the images are stored.
Because PGE Editor doesn't copies BMP's into pre-generated dummy world (trick used by PGE Editor to launch SMBX Test requires generating of a dummy episode), convert your image into PNG and that will work fine. I'll fix that in next commit, and you will be able to take fixed editor from laboratory
EDIT: Sent, wait ~1 hour while AppVeyor will build it, then take fresh build here ;)
Thank you for the quick response to the issue.

But about the other question:
Does PGE still allow to "Test in SMBX" without creating a dummy episode? By using the already opened SMBX editor?
(like this in this video: https://www.youtube.com/watch?v=fIyjAaNrhHw )
Or was this removed?
Image


Return to “A2XT”

Who is online

Users browsing this forum: No registered users and 1 guest

cron